Tray icon doesn't update

You've found a bug in PopMan? Tell me about it!

Moderator: Christian

Post Reply
User avatar
Jeroen
Posts: 53
Joined: 24 Jan 2005, 09:05
Location: Delft, Netherlands
Contact:

Tray icon doesn't update

Post by Jeroen » 09 Feb 2005, 17:15

I'm using 1.3b5, and it suddenly seems to have a little problem. The tray icon isn't updated in some time. It still shows 148, and when I put the mouse on it, it reads 148 messages in 3 accounts. Actually, there are only 3 messages in 2 accounts. These show up when I open the main window. When I click Update all my accounts are checked, no new messages, but still the tray icon reads 148 :-( I didn't restart my system yet, but I'll update this post after that. I didn't notice this behaviour before.

update: After a restart of my system the icon tray is okay, but it's still a strange situation!

Anyone else?

BTW: I posted this in the wrong section... sorry

User avatar
Christian
Site Admin
Posts: 315
Joined: 11 Jan 2004, 13:04
Location: Magdeburg, Germany
Contact:

Post by Christian » 09 Feb 2005, 21:38

This tray icon update problem, that you describe, is a known bug in PopMan since version 1.1, when the tray icon feature was introduced.

I experience the problem about 3 times a year. It seems PopMan loses the connection to the tray icon and is therefore unable to update it in any way. You have to restart PopMan to make the icon work again.

Because the problem occurs so seldom, it's extra hard to track it down. It is much easier to eliminate a crash, where you have an address to start from, or a bug that can be reproduced.

Maybe, anyone with programming experience can take a look at the PopMan source file "TrayIcon.cpp" to see if there is something that I have overlooked.

Please report any further occurence of this problem here...
Christian Hübner

murphylaws

Post by murphylaws » 12 Feb 2005, 10:44

funny, but it started to happen for me, also, only at version 1.3b5

does someone knows what action causes this problem?

User avatar
Jeroen
Posts: 53
Joined: 24 Jan 2005, 09:05
Location: Delft, Netherlands
Contact:

Post by Jeroen » 16 Feb 2005, 07:41

Just a wild guess:

I'm using PopMan on my notebook with a wireless connection, which means sometimes it can, and sometimes it can't make a connection with the mailservers. Isn't there a check in the program which prevents the icon from being updated after some mailchecks didn't work? I didn't test it, but it sounds like an option, doesn't it? ;-)

User avatar
Christian
Site Admin
Posts: 315
Joined: 11 Jan 2004, 13:04
Location: Magdeburg, Germany
Contact:

Post by Christian » 16 Feb 2005, 10:49

No, it is not a simple logical bug, because when terminating PopMan the tray icon still remains in the tray. You then have to move the mouse cursor over the icon, so Windows realizes, that there is no program assigned to it and removes it...
Christian Hübner

Post Reply