Connection Error 401, 1401 on Win 7 and older

General discussion about PopMan.

Moderator: Christian

Post Reply
User avatar
Christian
Site Admin
Posts: 368
Joined: 11 Jan 2004, 13:04
Location: Magdeburg, Germany
Contact:

Connection Error 401, 1401 on Win 7 and older

Post by Christian »

If you experience sudden connection problems (error code 401 or 1401) in PopMan running on Windows 7 or Windows XP, the reason is probably that your e-mail provider requires a secure connection using protocol TLS 1.2 or higher.

PopMan uses the encryption libraries of the Windows operating system. Windows 7 and older Windows versions by default do not support TLS 1.2. Therefore, PopMan is unable to establish a TLS 1.2 secured connection to your e-mail provider.

To fix this, you can enable support for TLS 1.2, e.g.:

https://manage.accuwebhosting.com/knowl ... ows-7.html

https://wiki.shackspace.de/project/tls_in_windows_xp

Note: For POP3 you can use the protocol "POP3 SSL". It supports TLS 1.2 without operating system support since PopMan version 1.3.16.
Christian Hübner
in3novs
Posts: 3
Joined: 04 Jun 2022, 11:18

Re: Connection Error 401, 1401 on Win 7 and older

Post by in3novs »

Many thanks.
The solution worked for PopMan on Win 7 and Win 10. Probably it will work
too on Win 11.
As a bonus, it allows to suppress the Google OAuth2's irritating
verification steps on Thunderbird
(even with "normal password" option, in my case).

For users already familiar with RegEdit, I provide a quick fix :

=== For Windows 7

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols
New KEY "TLS 1.2"
New sub-KEY > "Client"
New DWORD(32bit) Value : "DisabledByDefault" -- keep the value 0

Done. Reboot

=== For Windows 10, the update is the same with an additional sub-key

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols
New KEY "TLS 1.2"
New sub-KEY > "Client"
New DWORD(32bit) Value : "DisabledByDefault" -- keep the value 0
New DWORD(32bit) Value : "Enable" -- modify value to 1

Done. Reboot
Post Reply