Popman Stalls

You've found a bug in PopMan? Tell me about it!

Moderator: Christian

Post Reply
Wolfweb

Popman Stalls

Post by Wolfweb »

Sometimes a particular email wll stall popman so that it stops responding, I have to log into my mail account with a different email header checker and delete the message that stalls Popman before I can get past that message with popman.
User avatar
Christian
Site Admin
Posts: 324
Joined: 11 Jan 2004, 13:04
Location: Magdeburg, Germany
Contact:

Post by Christian »

I will need to have a look into the log file to investigate this issue.

Please verify that you have logging enabled: In the menu choose "Tools" > "Options" and check the option "Enable logging" on the "Logging" tab.

Reproduce the problem and send me the log file "PopManLogFile.log".

Thank you
Christian Hübner
Kaysea

Mine Stalls as Well.....

Post by Kaysea »

I'll send you the log file.... all the ones it stalls on, seem to be empty emails... When I check them through webmail, there's nothing there but the header, don't know whether this has anything to do with it or not.
Guest

Re: Mine Stalls as Well.....

Post by Guest »

Kaysea wrote:I'll send you the log file.... all the ones it stalls on, seem to be empty emails... When I check them through webmail, there's nothing there but the header, don't know whether this has anything to do with it or not.
Because the program froze, it wiped out the changes I'd made to recording the log file. Will have to remember to send it next time. :o\
User avatar
Jeroen
Posts: 53
Joined: 24 Jan 2005, 09:05
Location: Delft, Netherlands
Contact:

Post by Jeroen »

Here another one. One of my "spam-accounts" reports 93 messages, but popman always freezes after the 66th message, saying "Loading message 67 of 93...". CPU usage goes up to 95%, and I have to kill the application from the taskmanager.

I'll send you the logfile if it's any use!
User avatar
Christian
Site Admin
Posts: 324
Joined: 11 Jan 2004, 13:04
Location: Magdeburg, Germany
Contact:

Post by Christian »

popman always freezes after the 66th message
:shock:

Please send me the log file and I will have a look...
Christian Hübner
User avatar
Christian
Site Admin
Posts: 324
Joined: 11 Jan 2004, 13:04
Location: Magdeburg, Germany
Contact:

Post by Christian »

I've received your log file and was able to reproduce the problem. :)

There was a bug in PopMan's message body extraction routine, that caused an infinite loop due to a boundary mishandling under very special conditions (the boundary string was part of the message header).

I will include the fix with the 1.3 Beta 7 release in the next days...
Christian Hübner
Guest

Post by Guest »

Christian wrote:I've received your log file and was able to reproduce the problem. :)
Great, glad I could help!
Post Reply